1. The space forums use a separate registration system from the main virtual world. To comment on these forums, you need to create a separate forum account.
    Dismiss Notice
  2. Hey there, if you want some direct help without hopping inworld - try our Discord channel at https://discord.gg/mptfycQ
    Dismiss Notice

Bug Report AQUAS Lite water disables custom post-processing profile in the viewer.

Discussion in 'Bug Reports' started by Lex4art, Mar 27, 2018.

Share This Page

  1. Lex4art

    By:Lex4artMar 27, 2018
    Member

    Joined:
    Feb 9, 2017
    Messages:
    121
    Likes Received:
    15
    Subj. Adding an default AQUAS Lite water plane prefab with reflections on water enabled will switch off my global post-processing zone settings to default of something else. Temporary solution is to disable AQUAS object and create an animation that will enable it with 3 seconds delay - this way it won't broke post-processing (guess all this problem is about "post-processing layer script is attached to the first enabled camera he can get and it is camera of AQUAS Lite for realtime reflections"). Tested on 2018.3.b10 viewer.
     
    Last edited: Mar 27, 2018
  2. Trilo

    By:TriloMar 27, 2018
    Active Member

    Joined:
    Dec 6, 2016
    Messages:
    318
    Likes Received:
    46
    If this is in the same version of unity as your other post, using 2018.1b10 could be a factor - anything that changed under the hood between 2017.2.x and that release (which most definitely includes rendering) would likely have issues when being uploaded to a processing server and grid that's on 2017.2.x. For what it's worth I have not encountered issues with post zone/post processing profiles in Aquas Lite (back when I was using that) or Aquas full version (what I've been using in the last few months) on Unity 5.6.x (when that was current and I was using a matching Editor Pack) or Unity 2017.2.x (currently, and using EP12p8).
     
    Lex4art likes this.
  3. Lex4art

    By:Lex4artMar 27, 2018
    Member

    Joined:
    Feb 9, 2017
    Messages:
    121
    Likes Received:
    15
    Correction: I'm using Unity editor v2017.2.x - it's about viewer version is 2018.3.b10 (forgot about this ".3" in the middle, sorry for confusing!).