1. The space forums use a separate registration system from the main virtual world. To comment on these forums, you need to create a separate forum account.
    Dismiss Notice
  2. Hey there, if you want some direct help without hopping inworld - try our Discord channel at https://discord.gg/mptfycQ
    Dismiss Notice

Bug Report Standalone Gestures Fail to play/loop with v0.11.03

Discussion in 'Bug Reports' started by ghaelen, Nov 3, 2017.

Share This Page

  1. ghaelen

    By:ghaelenNov 3, 2017
    Sinespace Creator
    Staff Member Moderator

    Joined:
    Sep 29, 2016
    Messages:
    80
    Likes Received:
    25
    Update: Reinstalling both the installer and the current version of the viewer fixed the issue. Huzzah!

    I couldn't figure out why a new dance gesture wouldn't loop on the review server, no matter what I changed in the settings. It would play once, just fine. Then the animation stopped but the "Stop Looping" button was still present.

    Then I tried an existing (working) animation.That one wouldn't even play.

    I logged onto the Live server, and a similar issue happened. An existing gesture/animation played once but failed to loop. After waiting quite a while I tried another gesture. The avatar bopped into the ground and back up but never began to play the gesture animation.

    I tried a third animation on Live. The avatar moved it's feet briefly but never started the animation.

    I cleared the viewer cache and tested on both the review server and the Live server again. This time the Le Custard animation played once then the avatar stood and the looping stopped. I clicked the Stop Looping button. The animate camera box stayed on the UI screen for some time. After that no other animations would play longer than a blip in the avatar, as if it was trying to move but couldn't start the animation.

    I'm going to assume for now that my new gesture is OK, since existing gestures are also affected.
     
    Last edited: Nov 3, 2017
  2. Adam

    By:AdamNov 6, 2017
    Developer
    Staff Member Moderator

    Joined:
    Aug 21, 2014
    Messages:
    714
    Likes Received:
    148
    Hey there,

    Yes this was a nasty bug that slipped in the first version of the 1031 viewer, we released a hotfix for it later in the day, but the initial version was buggy. Reinstalling will fix it.